[Hackage] #380: Ability to blacklist packages that are on hackage

Hackage trac at galois.com
Wed Oct 22 20:46:39 EDT 2008

#380: Ability to blacklist packages that are on hackage
  Reporter:  guest               |        Owner:                    
      Type:  defect              |       Status:  new               
  Priority:  normal              |    Milestone:                    
 Component:  cabal-install tool  |      Version:           
  Severity:  normal              |     Keywords:  wishlist blacklist
Difficulty:  normal              |   Ghcversion:  6.8.3             
  Platform:                      |  
 Sometimes there are packages on hackage that I don't want to install,
 perhaps ever.  Maybe there is a buggy release I'm trying to avoid, or
 something of that nature.

 So, my proposal is a user defined blacklist.  I think the version
 specification could work just like that of a .cabal file.

 I also think cabal should tell you when it skips a dependency due to

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/380>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list