[Hackage] #376: Allow constraint on using installed package versions

Hackage trac at galois.com
Mon Oct 20 16:21:16 EDT 2008

#376: Allow constraint on using installed package versions
  Reporter:  duncan              |        Owner:        
      Type:  enhancement         |       Status:  new   
  Priority:  normal              |    Milestone:        
 Component:  cabal-install tool  |      Version:  HEAD  
  Severity:  normal              |   Resolution:        
  Keywords:                      |   Difficulty:  normal
Ghcversion:  6.8.3               |     Platform:        
Comment (by duncan):

 Replying to [comment:2 duncan]:
 > Perhaps as a diagnostic for the custom build type, cabal should check
 that the registered package is actually consistent with the info in the
 .cabal file.

 Note that this would frequently flag up packages built using franchise
 because it does not believe in specifying package deps. Rather it beleives
 in discovering required modules and at configure time discovering which
 packages provide those modules.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/376#comment:3>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list