preferred-versions and hackage index

Ross Paterson ross at
Thu Oct 9 17:53:37 EDT 2008

On Thu, Oct 09, 2008 at 01:28:31PM -0700, Duncan Coutts wrote:
> What needs to happen next is that these preferences be included into the
> hackage index that cabal-install and other clients download. This should
> be completely backwards compatible. The format allows for adding other
> files with different extensions and older clients will just ignore them.
> So if you don't mind what I'll do is to add a "preferred-versions" text
> file into the archive and adjust the script that generates the
> 00-index.tar.gz file to pick up that text file too.

I have no objection to this.

More information about the cabal-devel mailing list