[Hackage] #407: cabal-install-0.5 broken with ghc-6.10

Hackage trac at galois.com
Mon Nov 17 00:54:33 EST 2008

#407: cabal-install-0.5 broken with ghc-6.10
  Reporter:  Paul Visschers      |        Owner:        
      Type:  defect              |       Status:  closed
  Priority:  normal              |    Milestone:        
 Component:  cabal-install tool  |      Version:        
  Severity:  major               |   Resolution:  fixed 
  Keywords:                      |   Difficulty:  normal
Ghcversion:  6.10.1              |     Platform:  Linux 
Changes (by duncan):

  * status:  new => closed
  * version: =>
  * resolution:  => fixed
  * summary:  Installing new packages takes forever => cabal-install-0.5
              broken with ghc-6.10


 The version of cabal-install you are using is not compatible with
 ghc-6.10. You will need to upgrade to the latest version (cabal-

 If you now only have ghc-6.10 installed then you will have to install
 cabal-install without using the existing non-working version of cabal-
 install. If you've still got ghc 6.8 installed then it's slightly easier:

 cabal update
 cabal install -w ghc-6.8.2 cabal-install
 and the resulting version will work with 6.10 too.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/407#comment:1>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list