[Hackage] #393: Allow --preference= flags for soft constraints

Hackage trac at galois.com
Sat Nov 8 09:38:22 EST 2008

#393: Allow --preference= flags for soft constraints
  Reporter:  duncan              |        Owner:                   
      Type:  enhancement         |       Status:  new              
  Priority:  normal              |    Milestone:  cabal-install-0.6
 Component:  cabal-install tool  |      Version:          
  Severity:  normal              |     Keywords:                   
Difficulty:  easy (<4 hours)     |   Ghcversion:  6.8.3            
  Platform:                      |  
 `cabal install` now uses soft preferences from a `preferred-versions` file
 in the hackage index. It would sometimes be useful to also be able to
 specify these on the command line.

 It shouldn't be too hard since the solver already accepts such soft-

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/393>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list