Duncan Coutts duncan.coutts at
Sat Nov 1 16:57:30 EDT 2008

On Tue, 2008-10-21 at 10:51 +0200, Christian Maeder wrote:

> So network- should be linked against base-3 within the binary
> dist of ghc-6.10 (or not shipped with ghc-6.10 at all.
> In fact it worked after I've unregistered my global network-,
> first! (but I didn't get much further, see below)

network- is now on hackage which should resolve the issue.

> > Normally cabal-install would use base-3 but in this case it's picking 4
> > because the version that is already installed used 4 so the assumption
> > is that since the same version is already installed then it does indeed
> > work with base 4. Of course that's not true here because the package has
> > changed without the version being bumped.
> Or cabal-install should be smarter (or less smart).

Unfortunately it cannot be less smart or it'd try rebuilding haskell98
against base 3.

> So why is the version of network not bumped, yet? The maintainer is
> libraries at Would it interfere with ghc-6.8?

Done, and it works with (at least) ghc-6.6.1, 6.8.2 and 6.10.0.recent.


More information about the cabal-devel mailing list