[Hackage] #174: cabal-install tries to upgrade the base package

Hackage trac at galois.com
Wed May 21 11:59:27 EDT 2008

#174: cabal-install tries to upgrade the base package
  Reporter:  duncan              |        Owner:         
      Type:  defect              |       Status:  closed 
  Priority:  normal              |    Milestone:         
 Component:  cabal-install tool  |      Version:
  Severity:  normal              |   Resolution:  fixed  
  Keywords:                      |   Difficulty:  normal 
Ghcversion:  6.6                 |     Platform:  Linux  
Changes (by duncan):

  * status:  new => closed
  * resolution:  => fixed


 Wed May 21 16:37:00 BST 2008  Duncan Coutts <duncan at haskell.org>
   * Hide any available base and ghc-prim packages from the dep resolver
   Previously if the base package was available on hackage then the dep
   resolver might try to upgrade it. Unfortunately that's almost
   certainly technically impossible at the moment. So now since the dep
   resolver does not see these available packages it cannot pick them.
   This should fix ticket #174.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/174#comment:7>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list