patch applied (cabal): Make UTF-8 decoding errors in .cabal files non-fatal

Duncan Coutts duncan.coutts at
Fri Mar 28 09:53:04 EDT 2008

In message <20080328122052.GA21271 at> cabal-devel at writes:
> On Thu, Mar 27, 2008 at 04:39:17PM +0000, Duncan Coutts wrote:
> > So I think hackage should reject them with a suitable error message. I
> > can send a patch. On that topic in fact, I think all parser warnings
> > should be fatal errors as far as hackage is concerned.
> OK, parser warnings (including UTF decode errors) are now fatal.


Is that patch pushed to the repo? I don't see it yet. I've got a patch to update
generally to the latest Cabal api, though if you've got the utf warnings form
the latest cabal then have you had to make all those changes already?

> (When the decoder detects all the illegals, they'll be kept out.)

Yep, working on that.

> Existing Latin-1 .cabal files have been transliterated to UTF-8.

Fantastic, thanks.


More information about the cabal-devel mailing list