[Hackage] #93: Incorrect permissions on library install

Hackage trac at galois.com
Wed Mar 12 09:20:51 EDT 2008

#93: Incorrect permissions on library install
  Reporter:  guest          |        Owner:           
      Type:  defect         |       Status:  new      
  Priority:  normal         |    Milestone:  Cabal-1.6
 Component:  Cabal library  |      Version:  1.1.4    
  Severity:  normal         |   Resolution:           
  Keywords:                 |   Difficulty:  normal   
Ghcversion:  6.4.2          |     Platform:  Linux    
Changes (by duncan):

  * milestone:  Cabal-1.4 => Cabal-1.6


 This is actually quite hard because we have no way in Haskell of portably
 setting the permissions bits for user/group/other.

 We could do it perhaps if we used cpp and used functions from the posix

 I'm punting from the immediate milestone.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/93#comment:4>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list