Cabal bugs

Duncan Coutts duncan.coutts at
Wed Mar 5 10:34:05 EST 2008

On Wed, 2008-03-05 at 11:24 +0000, Neil Mitchell wrote:
> Hi
> >  And I've pushed the fix:
> >
> >  Wed Mar  5 02:36:26 GMT 2008  Duncan Coutts <duncan at>
> >   * Fix configure for hugs where we don't know what packages are installed
> >   For Hugs, nhc98 and other compilers we do not know what packages are
> Which works perfectly.
> Any chance that (if its not too much effort) cabal install on Hugs
> could just assume that all the necessary packages are already
> installed? It would at least give me the ability to do "cabal install
> --hugs" in a darcs repo, instead of three runhaskell Setup
> invocations.

Done. Give it a go...

In theory this might work too:
$ cabal install foobar
That is it should download and install foobar from hackage, assuming of
course that all of foobar's dependencies are already installed. Or if
foobar is already installed, then we'll install it again, yay!

I get some weird failures on installing cabal-install which go away when
I delete the pre-existing instllation of cabal-install. Also, user
installs are not going to work without tweaking the scripts that call
runhugs to adjust the search path to look at other user libs. Perhaps
you can send us a patch for that.

Perhaps it needs some fat warnings so people don't make the mistake of
assuming it's going to work.


More information about the cabal-devel mailing list