[Hackage] #58: allow darcs repo to be specified in cabal file

Hackage trac at galois.com
Tue Mar 4 15:37:46 EST 2008

#58: allow darcs repo to be specified in cabal file
  Reporter:  ijones         |        Owner:           
      Type:  enhancement    |       Status:  new      
  Priority:  high           |    Milestone:  Cabal-1.4
 Component:  Cabal library  |      Version:           
  Severity:  normal         |   Resolution:           
  Keywords:                 |   Difficulty:  normal   
Ghcversion:  6.2.1          |     Platform:  Linux    
Comment (by igloo):

 Replying to [comment:7 kolmodin]:
 > I'd like a tool that downloads the scm version of a cabal package. very
 simple yet I'd find it much useful.
 > {{{
 > cabal-source get zlib
 > }}}
 > should run darcs and give me the zlib repo in the current dir. Nice...

 I'd expect a `--development` flag, or similar, to be needed if you want
 the source from the RCS. Otherwise I'd expect it to give you the source
 from the latest tarball.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/58#comment:8>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list