Cabal install performs worse on Hugs

Duncan Coutts duncan.coutts at
Mon Jun 16 15:22:56 EDT 2008

On Sat, 2008-06-14 at 15:05 +0100, Neil Mitchell wrote:
> Hi,
> Using Cabal 1.4 Branch and Cabal-install HEAD:
> C:\Neil\uniplate>cabal install --hugs
> Resolving dependencies...

Should work now.

Also "cabal install --hugs whatever" should also work. It assumes that
all deps of "whatever" are already installed.

It can still go wrong. Suppose foo build-depends on bar < 2 but bar-2.0
is available, then:

$ cabal install foo bar

will will (probably) succeed, however it will pick bar-2.0 because it's
the latest available, even though foo cannot work with bar-2.0.

Perhaps there is in fact a way of working out what hugs packages are
installed. Each package that comes with hugs (2006.9 at least) has a
Paths_pkgname.hs module and it defines:
version = Version [...] []

So it would be possible to parse this to get the versions of all
installed packages.


More information about the cabal-devel mailing list