cabal-install failure: yi

Darrin Thompson darrinth at
Fri Jun 13 16:54:44 EDT 2008

I'm reposting this here as something bad appeared to happen to my post
on haskell-cafe and I probably should have posted here anyway.

Cabal-install is looking good. I needed only two deps outside of Cabal-1.4.

I installed cabal-install-0.5 on ubuntu with the linux
binary for ghc 6.8.2.

I then tried cabal-install yi

Got this output:
... many successful installs ...
Registering vty-3.0.1...
Reading package info from "dist/installed-pkg-config" ... done.
Saving old package config file... done.
Writing new package config file... done.
Downloading yi-0.3...
[1 of 1] Compiling Main             ( Setup.hs, dist/setup/Main.o )

   Warning: Deprecated use of `showPackageId'
            (imported from Distribution.Simple, but defined in
            use the Text class instead
Linking dist/setup/setup ...
Warning: defaultUserHooks in Setup script is deprecated.
Configuring yi-0.3...
Warning: Instead of 'ghc-options: -DDYNAMIC -DFRONTEND_VTY' use
setup: alex version >=2.0.1 && <3 is required but it could not be found.
cabal: Error: some packages failed to install:
yi-0.3 failed during the configure step. The exception was:
exit: ExitFailure 1

Is this a cabal problem of package problem? I would have expected it
to fail immediately instead of discover this problem so far into



More information about the cabal-devel mailing list