[Hackage] #194: add sanity checking to version numbers

Hackage trac at galois.com
Tue Jan 22 19:53:50 EST 2008

#194: add sanity checking to version numbers
  Reporter:  duncan         |        Owner:                     
      Type:  defect         |       Status:  new                
  Priority:  normal         |    Milestone:                     
 Component:  Cabal library  |      Version:            
  Severity:  normal         |   Resolution:                     
  Keywords:                 |   Difficulty:  very easy (<1 hour)
Ghcversion:  6.8.1          |     Platform:  Linux              
Comment (by duncan):

 Replying to [comment:2 ross at soi.city.ac.uk]:
 > Replying to [comment:1 duncan]:
 > > Turns out that there are zero packages in hackage with this kind of
 dodgy version number.
 > That is not an accident; they're forbidden because they would break

 Right. I should not have been surprised. :-)

 So since things are in a good state lets just take a hard line everywhere.
 It's a good deal easier than trying to add warnings in the right places.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/194#comment:3>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list