[Hackage] #436: cabal-install readme could mention zlib dependency

Hackage trac at galois.com
Sat Dec 20 11:13:41 EST 2008

#436: cabal-install readme could mention zlib dependency
  Reporter:  Benja                |        Owner:         
      Type:  enhancement          |       Status:  new    
  Priority:  low                  |    Milestone:         
 Component:  cabal-install tool   |      Version:
  Severity:  normal               |     Keywords:         
Difficulty:  very easy (<1 hour)  |   Ghcversion:  6.8.3  
  Platform:                       |  
 Hi all,

 The cabal-install README mentions the dependency on the zlib Haskell
 package, which is pulled in by bootstrap.sh, but not on the C library,
 which isn't. It might be useful to mention it (Ubuntu package: "zlib1g-
 dev") in the installation instructions/quickstart sections of the README
 (it took me a moment to figure out why the build was failing even though I
 was following instructions, and which package I needed).

 - Benja

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/436>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list