[Hackage] #434: Let packages opt-in to the Package Versioning Policy

Hackage trac at galois.com
Thu Dec 18 17:15:06 EST 2008

#434: Let packages opt-in to the Package Versioning Policy
  Reporter:  duncan         |        Owner:           
      Type:  enhancement    |       Status:  new      
  Priority:  normal         |    Milestone:  Cabal-1.8
 Component:  Cabal library  |      Version:  
  Severity:  normal         |     Keywords:           
Difficulty:  normal         |   Ghcversion:  6.8.3    
  Platform:                 |  
 Package version numbers and version constraints on dependencies are
 proxies for API compatibility. It is hard for people to specify the
 dependencies correctly and we would like to improve their quality.

 We have the [http://haskell.org/haskellwiki/Package_versioning_policy
 Package versioning policy] which says how the package version number
 relates to API changes.

 What we want is a mechanism by which package authors can opt-in to the
 versioning policy. We should then get hackage to check that the package
 really is following the policy. Just as important we can use the fact that
 a package does follow the policy to give suggestions to package authors.
 For one thing we can discourage or ban upwardly open version ranges and
 provide a suggestion on what upper version bound to use.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/434>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list