[Hackage] #432: cabal-install patches for HTTP 4000.0.0

Hackage trac at galois.com
Mon Dec 15 17:16:15 EST 2008

#432: cabal-install patches for HTTP 4000.0.0
  Reporter:  Bart Massey         |        Owner:           
      Type:  enhancement         |       Status:  new      
  Priority:  normal              |    Milestone:  Cabal-1.8
 Component:  cabal-install tool  |      Version:  HEAD     
  Severity:  normal              |     Keywords:           
Difficulty:  normal              |   Ghcversion:  6.10.1   
  Platform:                      |  
 I noticed that the constraints on the packages for cabal-install required
 some pretty old stuff.  Rather than go there, I decided to loosen the
 constraints and see what happened.

 The current version of Cabal (1.7) and zlib ( seem to work fine.
 Some patches were required to get current HTTP (4000.0.0) to work.  I
 attach these patches in case anyone cares.

 I have done no testing of these patches other than trying a few simple
 cabal commands.  They seemed to work.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/432>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list