[Hackage] #419: cabal-install should handle packages that need a later Cabal version better

Hackage trac at galois.com
Mon Dec 1 11:02:57 EST 2008

#419: cabal-install should handle packages that need a later Cabal version better
  Reporter:  jimburton           |        Owner:         
      Type:  defect              |       Status:  new    
  Priority:  normal              |    Milestone:         
 Component:  cabal-install tool  |      Version:
  Severity:  normal              |   Resolution:         
  Keywords:                      |   Difficulty:  normal 
Ghcversion:  6.8.3               |     Platform:         
Comment (by jimburton):

 Replying to [comment:1 duncan]:
 > The problem is that cgi-3001.1.7.1 uses syntax that is new in Cabal-1.6
 and your version of cabal-install is using Cabal-1.4. So it's not that the
 file is missing (it isn't) but the .cabal file cannot be parsed.
 > Try upgrading cabal-install and try again:
 > `cabal install cabal-install`

 Thanks, but upgrading Cabal lib and cabal-install haven't helped. I
 couldn't upgrade Cabal with cabal-install ("No packages to install") so I
 downloaded Cabal 1.6 and installed it myself then used ghc-pkg to
 unregister older version of Cabal. Then I reinstalled cabal-install but it
 is still reporting the older version of cabal:

 jim at mowa624-jb162:~$ ghc-pkg list
     HTTP-3001.0.4, HUnit-, QuickCheck-, array-,
     base-, binary-, bytestring-, cgi-3001.1.6.0,
     containers-, directory-, fgl-,
     filepath-, {ghc-6.8.3}, haskell-src-,
     haskell98-, hpc-, html-, mtl-,
     network-, old-locale-, old-time-,
     packedstring-, parallel-, parsec-,
     pretty-, process-, random-, readline-,
     regex-base-, regex-compat-, regex-posix-,
     rts-1.0, stm-, template-haskell-, time-,
     unix-, xhtml-3000.2.0.0, zlib-
     Agda-2.1.3, Cabal-, HTTP-3001.1.3, HTTP-3001.1.4,
     QuickCheck-, QuickCheck-, X11-1.4.3, X11-xft-0.3,
     binary-, binary-0.4.4, bytestring-, cgi-3001.1.7.0,
     fgl-, haskell-src-, html-, mtl-,
     network-, network-, parsec-3.0.0, regex-base-0.93.1,
     regex-compat-0.92, regex-posix-0.93.2, stm-, time-,
     utf8-string-, utf8-string-0.3.2, xhtml-3000.2.0.1,
     xmonad-0.8, xmonad-contrib-0.8, zlib-
 jim at mowa624-jb162:~$ cabal install cabal-install
 Resolving dependencies...
 'cabal-install-0.6.0' is cached.
 Configuring cabal-install-0.6.0...
 Preprocessing executables for cabal-install-0.6.0...
 Building cabal-install-0.6.0...
 [ 1 of 29] Compiling Distribution.Client.Utils (
 Distribution/Client/Utils.hs, dist/build/cabal
 [29 of 29] Compiling Main             ( ./Main.hs, dist/build/cabal/cabal-
 tmp/Main.o )
 Linking dist/build/cabal/cabal ...
 Installing: /home/jim/.cabal/bin
 jim at mowa624-jb162:~$ cabal --version
 cabal-install version 0.5.2
 using version of the Cabal library


 And cabal upgrade still doesn't work. I thought I might need to clean and
 reconfigure the cabal-install package myself so I tried that too, manually
 deleting ~/.cabal/bin/cabal and using `runhaskell Setup.hs --user ...' etc
 in the packages directory. After that I am still told I'm using Cabal 1.4.


Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/419#comment:2>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list