[Hackage] #395: Warn about dependencies like parsec <=

Hackage trac at galois.com
Mon Dec 1 04:37:20 EST 2008

#395: Warn about dependencies like parsec <=
  Reporter:  duncan         |        Owner:                     
      Type:  enhancement    |       Status:  new                
  Priority:  normal         |    Milestone:                     
 Component:  Cabal library  |      Version:                     
  Severity:  normal         |   Resolution:                     
  Keywords:                 |   Difficulty:  very easy (<1 hour)
Ghcversion:  6.8.3          |     Platform:                     
Changes (by duncan):

 * cc: Saizan (added)


 In #418 Saizan notes:

 Dependencies of the form "foo > x" don't really make sense given the
 hackage version policy, since they exclude x but include x.y which is
 supposed to have a similar api, and if you want something introduced in a
 minor (or lesser) release you can explicitly mention that.

 Also what is often intended with that notation is foo >= (x+1), causing

 I propose that we allow only closed lower bounds, i.e. foo >= x.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/395#comment:2>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list