[Hackage] #327: should require minimum c2hs version of 0.15

Hackage trac at galois.com
Mon Aug 18 20:54:42 EDT 2008

#327: should require minimum c2hs version of 0.15
  Reporter:  duncan               |        Owner:         
      Type:  defect               |       Status:  new    
  Priority:  normal               |    Milestone:         
 Component:  Cabal library        |      Version:
  Severity:  normal               |     Keywords:         
Difficulty:  very easy (<1 hour)  |   Ghcversion:  6.8.2  
  Platform:                       |  
 Cabal does not work with c2hs older than 0.15. With older c2hs versions
 the .hs file ends up in the wrong location in the build tree.

 If we find that c2hs is needed for the build then we should check that it
 meets this minimum version.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/327>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list