[Hackage] #326: Cabal should support Cabal-version-dependent Setup.hs

Hackage trac at galois.com
Mon Aug 18 12:14:08 EDT 2008

#326: Cabal should support Cabal-version-dependent Setup.hs
  Reporter:  claus          |        Owner:         
      Type:  enhancement    |       Status:  new    
  Priority:  normal         |    Milestone:         
 Component:  Cabal library  |      Version:
  Severity:  normal         |   Resolution:         
  Keywords:                 |   Difficulty:  normal 
Ghcversion:  6.8.2          |     Platform:         
Comment (by duncan):

 We don't make these macros available to `Setup.hs` scripts and it's not
 entirely clear that we should as it'd then be much harder to compile the
 scripts using anything other than cabal-install. For example distro
 packaging scripts need to be able to compile the Setup.hs scripts.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/326#comment:5>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list