[Hackage] #163: cpp-options field required

Hackage trac at galois.com
Fri Oct 26 07:54:15 EDT 2007

#163: cpp-options field required
  Reporter:  duncan  |        Owner:           
      Type:  defect  |       Status:  closed   
  Priority:  normal  |    Milestone:  Cabal-1.2
 Component:  Cabal   |      Version:  1.2.0    
  Severity:  normal  |   Resolution:  fixed    
  Keywords:          |   Difficulty:  normal   
Ghcversion:  6.4.2   |     Platform:  Linux    
Changes (by duncan):

  * status:  new => closed
  * resolution:  => fixed


 The "cpp-options:" field is implemented in Cabal-1.2.1. It applies to
 haskell source and other pre-processed Haskell source like .hsc .chs. It
 does not apply to C code, that's what cc-options is for.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/163#comment:2>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list