[Haskell] Re: Trying to install binary-0.4

Ross Paterson ross at soi.city.ac.uk
Wed Oct 17 09:44:19 EDT 2007

On Wed, Oct 17, 2007 at 12:54:12PM +0100, Simon Marlow wrote:
> I've written down the proposed policy for versioning here:
>   http://haskell.org/haskellwiki/Package_versioning_policy
> It turned out there was a previous page written by Bulat that contained 
> essentially this policy, but it wasn't linked from anywhere which explains 
> why it was overlooked.  I took the liberty of rewriting the text.

You wrote:

> A client that wants to specify that they depend on a particular version
> of the API can specify a particular A.B.C and be sure of getting that
> API only. For example, build-depends: mypkg-2.1.1

Are you proposing an extension along the lines of that proposed by
Thomas (and Bulat, and others), i.e. this would be equivalent to
build-depends: mypkg >= 2.1.1 && < 2.1.2 ?

The current syntax of mypkg == 2.1.1 would match the initial release
but not subsequent patch releases.

More information about the cabal-devel mailing list