[Hackage] #172: cabal-install segfaults

Hackage trac at galois.com
Wed Nov 7 14:55:47 EST 2007

#172: cabal-install segfaults
  Reporter:  guest          |        Owner:     
      Type:  defect         |       Status:  new
  Priority:  normal         |    Milestone:     
 Component:  cabal-install  |      Version:     
  Severity:  normal         |     Keywords:     
Difficulty:  normal         |   Ghcversion:  6.6
  Platform:  Linux          |  
 Using the newest library version on hackage, "cabal update" segfaults
 after downloading the package list from hackage. "cabal install" produces
 the error
 "cabal: Data.ByteString.Lazy.index: index too large: 0"

 steps to reproduce the problem (at least for me): install the newest
 versions of Cabal (, HTTP (3001.0.0), and zlib ( from
 hackage, compile and install cabal-install (0.4.0) from hackage, create a
 directory called dist (to circumvent another problem with cabal-install),
 run cabal update, or cabal install

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/172>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list