[Hackage] #170: pkg-config uses a more general version scheme

Hackage trac at galois.com
Mon Nov 5 17:35:56 EST 2007

#170: pkg-config uses a more general version scheme
  Reporter:  duncan  |        Owner:         
      Type:  defect  |       Status:  new    
  Priority:  low     |    Milestone:         
 Component:  Cabal   |      Version:
  Severity:  normal  |     Keywords:         
Difficulty:  normal  |   Ghcversion:  6.4.2  
  Platform:  Linux   |  
 From {{{HsOpenSSL.cabal}}}

   --PkgConfig-Depends: openssl >= 0.9.7l
   -- We really should use this instead of the configure
   -- script but Cabal can't handle the weird version
   -- scheme of OpenSSL.

 For example:

 $ pkg-config --modversion openssl

 Currently Cabal tries to map pkg-config versions to the standard
 {{{Version}}} type which only allows for a sequence of numbers.

 pkg-config uses just strings to represent package versions. It uses code
 lifted from rpm to compare version strings. See the {{{compare_versions}}}
 function in {{{pkg-gconfig-0.22/pkg.c}}} from

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/170>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list