Dependencies/backwards compatibility in Hackage

Ross Paterson ross at
Thu Feb 1 09:58:25 EST 2007

On Thu, Feb 01, 2007 at 03:36:00PM +0100, Björn Bringert wrote:
> I think that the correct solution to this problem would be to make a
> new release of haxr (which used to be XmlRpc) that works with HaXml 1.17.

rss also uses HaXml.  I'm not sure if Malcolm intends HaXml 1.17 to be
released yet.

> On a side note, I think that XmlRpc should be removed, or there should 
> be a way for one package to obsolete another. The XmlRpc package has 
> been renamed to haxr, to have a more uniform naming within the
> package.

It is gone.

More information about the cabal-devel mailing list