Thomas Schilling nominolo at
Thu Aug 16 13:16:30 EDT 2007

On 8/16/07, Malcolm Wallace <Malcolm.Wallace at> wrote:
> As a newbie to the cabal-devel list, I don't know whether this question
> has already been thought about much, and perhaps even has a really good
> answer.
> I notice that the Cabal darcs repo now has a Cabal.cabal file that uses
> configurations.  Presumably this is self-bootstrapping.  But is it still
> possible to upgrade an older version of Cabal (e.g. supplied with
> ghc-6.2) to the latest version, using only the older version of Cabal
> itself?

No.  Unfortunately, checking for the right cabal version is done after
parsing, but exactly then do we get errors with the new syntax.

Cabal bootstraps via a makefile, and this seems to work fine.  For
Windows, we might need a .bat file some time.  Are there any other
reasons why this should be possible?

"Remember! Everytime you say 'Web 2.0' God kills a startup!" -, Jul 31, 2006

More information about the cabal-devel mailing list