please try this tiny script to test cabal-install

Isaac Jones ijones at
Fri Sep 15 14:22:06 EDT 2006

"Jason Dagit" <dagit at> writes:

> The script test-cabal-install fails with this messages:
> ./setup build
> setup: Warning: The field "hs-source-dir" is deprecated, please use
> hs-source-dirs.
> Preprocessing executables for cabal-install-0.3.0...
> Building cabal-install-0.3.0...
> Chasing modules from: src/CabalInstall.hs
> Could not find module `Distribution.Compat.FilePath':
>  it is hidden (in package Cabal-1.1.5)
>  (imported from src//Network/Hackage/CabalInstall/Install.hs)
> make: *** [build] Error 1
> The reason for this error is that cabal does not set the permissions
> on freshly installed librarys correctly on my machine.  I don't know
> why this is the case, but I can provide information about my setup.

Thanks for the report!  I think that this has already been fixed with
the new cabal release.  Is that so, Duncan?

We had thought to hide FilePath, but it's apparently too popular to
keep from the people.



More information about the cabal-devel mailing list