[C2hs] .deb packages and problem in compilation

Manuel M T Chakravarty chak at cse.unsw.edu.au
Mon Nov 14 09:36:54 EST 2005


> I'm packaging c2hs for debian, and the 0.13.6 packages are in the
> mirror, if you could add this in the website.

Great - thanks!

> Another thing is that I'm having a problem in compiling c2hs 0.14.3:
> Chasing modules from: c2hs/toplevel/Main.hs
> Could not find module `CForeign':
>   use -v to see a list of the files searched for
>   (imported from c2hs/toplevel/C2HSConfig.hs)
> marcot at tonhao:~/desenvolvimento/debian/c2hs/c2hs-0.14.3$
> Do you know what is the problem here?

At line 18 of "c2hs.cabal", you need to insert a line

Build-Depends:  base, haskell98

This problem occurs only since GHC 6.4.1.  A patch is in the darcs repo.


More information about the C2hs mailing list