<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">Hi,<br>
      <br>
      W dniu 20.01.2014 08:06, Pyro Crane pisze:<br>
    </div>
    <blockquote
      cite="mid:8D0E3C54A1B31F9-BFC-663E@webmail-m161.sysops.aol.com"
      type="cite"><font color="black" face="arial" size="2">
        <div><font face="arial">Hello again.</font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial">Thank you all for your very helpful
            replies  (below)</font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial">Here is the error I got when I tried to
            run my script :</font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial"><b>Could not find module `Graphics.GD'</b></font></div>
        <div><font face="arial"><b>Locations searched:</b></font></div>
        <div><font face="arial"><b>Graphics/GD.hs</b></font></div>
        <div><font face="arial"><b>Graphics/GD.lhs</b></font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial">As with the previous errors, I went on
            Google, to find out which module and/or package I needed to
            install.</font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial">Apparently, I need something called "GD"</font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial">When I tried :   <b>cabal install gd</b></font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial">I got the following :</font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><font face="arial"><b>Resolving dependencies...</b></font></div>
        <div><font face="arial"><b>Configuring gd-3000.7.3...</b></font></div>
        <div><font face="arial"><b>cabal-1.16.0.2: Missing dependencies
              on foreign libraries:</b></font></div>
        <div><font face="arial"><b>* Missing (or bad) header file: gd.h</b></font></div>
        <div><font face="arial"><b>* Missing C libraries: gd, expat</b></font></div>
        <div><font face="arial"><br>
          </font></div>
        <div><br>
        </div>
        <div><font face="arial"><b>Failed to install gd-3000.7.3</b></font></div>
        <div><font face="arial"><b>cabal-1.16.0.2: Error: some packages
              failed to install:</b></font></div>
        <div><b><font face="arial">gd-3000.7.3 failed during the
              configure step.  The exception was: </font><span
              style="font-family: arial; font-size: 10pt;">ExitFailure 1</span></b></div>
        <div style="color: black; font-family: arial; font-size: 10pt;"><br>
        </div>
        <div style="color: black; font-family: arial; font-size: 10pt;"><br>
        </div>
        <div style="color: black; font-family: arial; font-size: 10pt;"><br>
        </div>
        <div><br>
        </div>
        Upon further inquiries via google,  I found somewhere the
        following :
        <div><br>
        </div>
        <div><br>
        </div>
        <div>
          <div><font face="arial"><b>This problem can usually be solved
                by installing the system packages that</b></font></div>
          <div><font face="arial"><b>provide these libraries (you may
                need the "-dev" versions). If the libraries</b></font></div>
          <div><font face="arial"><b>are already installed but in a
                non-standard location then you can use the</b></font></div>
          <div><font face="arial"><b>flags --extra-include-dirs= and
                --extra-lib-dirs= to specify where they are.</b></font></div>
          <div><br>
          </div>
          <div><br>
          </div>
          <div><br>
          </div>
          <div>I thought I did this already.  </div>
          <div><br>
          </div>
          <div>But, apparently, I did something wrong??</div>
          <div><br>
          </div>
          <div><br>
          </div>
        </div>
      </font></blockquote>
    <br>
      This haskell package provides only library bindings. You need to
    install original library using system package manager.<br>
    <br>
    <font size="2"><font face="arial">Regards,<br>
        <font size="2">Emanuel<br>
          <br>
        </font></font></font>
  </body>
</html>