[Haskell-beginners] How to install new GHC ?

Baa aquagnu at gmail.com
Tue Dec 12 11:56:03 UTC 2017

Hello, All,

I want to switch to the new GHC (8.2.2) because I hit some
bug in GHC and suppose that it may be fixed in the new version. So, to
try it I changed "resolver: XXX" in my .yaml-files to "lts-9.18". Also I
done something else (I don't remember what exactly) and call
`stack setup ... --reinstall ...`. New GHC have been installed. And I
switched to new LTS - I see it 100%.
But when I run `stack build`, IMHO compiller is old, because if I call
`stack ghci` I see that old GHC (8.0.2) is calling. I'm not familiar
with stack/Haskell tools in-depth and may miss something! For example,
I know that LTS-9.18 is last stable, GHC 8.2.2 is last too, but in
Stackage seems that 9.18 corresponds to 8.2.2.

If I run `stack setup` in the directory with my project again I get:

stack will use a sandboxed GHC it installed
For more information on paths, see 'stack path' and 'stack exec env'
To use this GHC and packages outside of a project, consider using:
stack ghc, stack ghci, stack runghc, or stack exec

Would somebody explain me what is wrong here and how I can test a
project with new 8.2.2 GHC?

Best regards, Paul

More information about the Beginners mailing list