[Haskell-beginners] cabal install local troubles (osx)

Miro Karpis miroslav.karpis at gmail.com
Wed Mar 27 07:16:53 CET 2013

please, can you help me with following. I have installed haskell on mac
from the package. When I check cabal -V I can see 1.14.0
That is because the cabal is loading from /Library/Haskell/bin.

After that I run 'cabal install cabal-install', I get following output:

Installing executable(s) in
Updating documentation index /Users/miro/Library/Haskell/doc/index.html

So the new version of cabal is installed in another place. When I install
new package via cabal, it uses the 1.14.0 version. I have tried to copy the
new version to bin, but that just didn't help because the new
packages have been installed somewhere else.

Please what is the proper way to fix this?

many thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/beginners/attachments/20130327/20663285/attachment.htm>

More information about the Beginners mailing list