[Haskell-beginners] conduit and happstack dependence problem

Jeremy Shaw jeremy at n-heptane.com
Fri Oct 12 22:28:08 CEST 2012

The highest version of transformers on hackage is transformers-

The darcs version of transformers is only at


And even in the git version of conduits.cabal:


the version bounds is:

 transformers             >= 0.2.2        && < 0.4

According to packdeps the only upper bounds limitation with
happstack-server at the moment is base64-bytestring:

 $ packdeps happstack-server/happstack-server.cabal
happstack-server-7.0.4: Cannot accept the following packages

I'll bump that in the near future.

- jeremy

On Fri, Oct 12, 2012 at 2:59 PM, Antoine Latter <aslatter at gmail.com> wrote:
> CCing happstack mailing list.
> On Fri, Oct 12, 2012 at 1:52 PM, Никитин Лев <leon.v.nikitin at pravmail.ru> wrote:
>> I'm using conduit to download and parsing file. Conduit depens on
>> transformers >= 0.4.
>> Now I'm going to use happstack, but happstack-server depends on transformers
>> < 0.4.
>> Is there a way to use conduit and happstack together?
>> _______________________________________________
>> Beginners mailing list
>> Beginners at haskell.org
>> http://www.haskell.org/mailman/listinfo/beginners
> --
> You received this message because you are subscribed to the Google Groups "HAppS" group.
> To post to this group, send email to happs at googlegroups.com.
> To unsubscribe from this group, send email to happs+unsubscribe at googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/happs?hl=en.

More information about the Beginners mailing list