[Haskell-beginners] Cannot Install Yi - Haskell

Daniel Fischer daniel.is.fischer at googlemail.com
Sat Mar 26 13:59:49 CET 2011

On Saturday 26 March 2011 13:47:54, Sayth Renshaw wrote:
> this failed though because among other things glib would not install.
> from the error messages gtk2hs-buildtools was advised to be installed.
> So I installed that.
> Then I attempted to use $ cabal install yi -f-vty -fpango again but
> still glib fails.
> glib cannot be installed because of below error. Any further ideas?
> \setup.exe ...
> Configuring glib-0.12.0...
> setup.exe: The program pkg-config version >=0.9.0 is required but it
> could not
> be found.
> cabal: Error: some packages failed to install:
> glib-0.12.0 failed during the configure step. The exception was:
> ExitFailure 1
> C:\Documents and Settings\renshaw>cabal install pkg-config
> cabal: There is no package named 'pkg-config'.
> You may need to run 'cabal update' to get the latest list of available
> packages.

pkg-config is not a Haskell thing, it's a C (I think) tool. Unixoids 
usually come equipped with pkg-config, on Windows you have to install it 
otherwise (google pkg-config for Windows, that should turn up something 

More information about the Beginners mailing list