[Haskell-beginners] Cannot Install Yi - Haskell 2011.02.0.0

Daniel Fischer daniel.is.fischer at googlemail.com
Sat Mar 26 13:55:26 CET 2011

On Saturday 26 March 2011 10:33:24, Sayth Renshaw wrote:
> Actually I cannot install Yi on mint debian either. Cabal version
> doesn't match.
> I did cabal install cabal-install
> then
> cabal upgrade cabal
> but get this error when trying to install Yi
> Installing library in /home/sayth/.cabal/lib/Cabal-
> Registering Cabal-
> sayth at homegroup ~ $ cabal install yi
> Resolving dependencies...
> cabal: dependencies conflict: ghc-6.12.1 requires Cabal ==
> however Cabal- was excluded because yi- requires Cabal
> ==1.10.*

Yes, the ghc lib requires the Cabal it was built against. You can either 
try installing an earlier version of Yi which works with Cabal-1.8.*
or upgrading to GHC-7 (which comes with Cabal-1.10).

More information about the Beginners mailing list