[Haskell-beginners] Can't reproduce the build failure of my package on hackage

Daniel Seidel ds at iai.uni-bonn.de
Fri Feb 25 08:11:41 CET 2011


a while ago I uploaded a package to Hackage
( http://hackage.haskell.org/package/SBench ).
I checked it with ghc-6.12.3 and it worked well. The uploaded version
was tried to compile via ghc-7 and failed with the following log:

cabal: dependencies conflict: haskell98- requires time ==
time- was excluded because gnuplot-0.4.1 requires time ==1.1.*

Now, on Hackage, the latest haskell98 version is and it does, at least directly, *not* depend on time.
To figure out the problem I installed ghc-7.0.1 and tried to install my package. It worked.

Can anyone give me a hint why compilation fails on Hackage and where haskell98- comes from?

I want to upload a new version because I needed to adjust to the
'-rtsopts' flag in ghc 7. Before doing so it would be great to ensure
the new upload will compile on Hackage. A way might be to restrict
haskell98 to be less or equal to, but I think it's not a good



More information about the Beginners mailing list