[Haskell-beginners] Anyone have problems with cabal and SDL?

Tom Murphy amindfv at gmail.com
Tue Feb 22 15:53:08 CET 2011

I'm using Mac OS X 10.6.

Sorry, everyone, for just dumping a bunch of terminal output here, but:
When I tried to install SDL-0.6.2 in Cabal, I ultimately end up with the
same error:

cm-macbookpro-3:roadmap colinmurphy$ cabal install -v SDL-0.6.2
/opt/local/bin/ghc --numeric-version
looking for package tool: ghc-pkg near compiler in /opt/local/bin
found package tool in /opt/local/bin/ghc-pkg
/opt/local/bin/ghc-pkg --version
/opt/local/bin/ghc --supported-languages
Reading installed packages...
/opt/local/bin/ghc-pkg dump --global
/opt/local/bin/ghc-pkg dump --user
Reading available packages...
Resolving dependencies...
selecting SDL-0.6.2 (hackage)
selecting base- (installed) and (installed) and discarding
syb-,,,, 0.2, 0.2.1, 0.2.2 and 0.3
selecting ghc-prim- (installed)
selecting integer- (installed)
selecting rts-1.0 (installed)
selecting syb- (installed)
In order, the following would be installed:
SDL-0.6.2 (new package)
SDL-0.6.2 has already been downloaded.
to /var/folders/+p/+pUVycVKFDWsYP8YiYnM3k+++TM/-Tmp-/SDL-0.6.26837...
(and its parents)
/opt/local/bin/ghc --make
-package Cabal-
[1 of 1] Compiling Main             (

    Warning: In the use of `defaultUserHooks'
             (imported from Distribution.Simple):
             Deprecated: "Use simpleUserHooks or autoconfUserHooks, unless
you need Cabal-1.2
             compatibility in which case you must stick with
ld: warning: -read_only_relocs cannot be used with x86_64
configure --verbose=2 --ghc --prefix=/Users/colinmurphy/.cabal --user
--constraint=base ==
Warning: defaultUserHooks in Setup script is deprecated.
Configuring SDL-0.6.2...
Dependency base >=3 && <5 && == using base-
Using Cabal- compiled by ghc-6.10
Using compiler: ghc-6.10.4
Using install prefix: /Users/colinmurphy/.cabal
Binaries installed in: /Users/colinmurphy/.cabal/bin
Libraries installed in: /Users/colinmurphy/.cabal/lib/SDL-0.6.2/ghc-6.10.4
Private binaries installed in: /Users/colinmurphy/.cabal/libexec
Data files installed in: /Users/colinmurphy/.cabal/share/SDL-0.6.2
Documentation installed in: /Users/colinmurphy/.cabal/share/doc/SDL-0.6.2
Using alex version 2.3.1 found on system at: /opt/local/bin/alex
Using ar found on system at: /usr/bin/ar
No c2hs found
No cpphs found
No ffihugs found
Using gcc version 4.2.1 found on system at: /usr/bin/gcc
Using ghc version 6.10.4 found on system at: /opt/local/bin/ghc
Using ghc-pkg version 6.10.4 found on system at: /opt/local/bin/ghc-pkg
No greencard found
Using haddock version 2.4.2 found on system at: /opt/local/bin/haddock
Using happy version 1.18.4 found on system at: /opt/local/bin/happy
No hmake found
Using hsc2hs version 0.67 found on system at: /opt/local/bin/hsc2hs
No hscolour found
No hugs found
No jhc found
Using ld found on system at: /usr/bin/ld
No nhc98 found
Using pkg-config version 0.25 found on system at: /opt/local/bin/pkg-config
Using ranlib found on system at: /usr/bin/ranlib
Using strip found on system at: /usr/bin/strip
Using tar found on system at: /usr/bin/tar
sh configure --with-hc=ghc --prefix=/Users/colinmurphy/.cabal
configure: WARNING: unrecognized options: --with-hc
checking for sdl-config... no
checking for sdl11-config... no
configure: error: *** SDL not found! Get SDL from www.libsdl.org.
If you already installed it, check it's in the path. If problem remains,
please send a mail to the address that appears in ./configure --version
indicating your platform, the version of configure script and the problem.
cabal: Error: some packages failed to install:
SDL-0.6.2 failed during the configure step. The exception was:
exit: ExitFailure 1
cm-macbookpro-3:roadmap colinmurphy$

The final error is different, but it's still before the claim that SDL-0.6.2
can't be found.

Thanks for any help!

On Mon, Feb 21, 2011 at 2:23 PM, Stephen Tetley <stephen.tetley at gmail.com>wrote:

> Hi Tom
> What OS are you using?
> Could you try to install SDL-0.6.2 (i.e. the Haskell binding) with the
> verbose output from Cabal, probably -v for the command line switch.
> _______________________________________________
> Beginners mailing list
> Beginners at haskell.org
> http://www.haskell.org/mailman/listinfo/beginners
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/beginners/attachments/20110222/70f0bead/attachment.htm>

More information about the Beginners mailing list