[Haskell-beginners] Happstack dependency problems

Tom Murphy amindfv at gmail.com
Wed Apr 6 06:40:19 CEST 2011

> It requires unix-compat to build. What does "cabal install
> unix-compat" give you?

The same error. But...

> If that's what's breaking you can try "cabal install
> unix-compat-" and then "cabal install happstack-util". Version
> appears to be the most recent version of unix-compat that
> doesn't specify version bounds on the unix package, which is what
> you're having trouble with.
This worked, then "cabal install happstack" worked perfectly(!)
     Can anyone point me to a tutorial which explains basics of cabal? I'm
trying to navigate it, without understanding version bounds, or really
anything related to how cabal handles versions of dependencies.

Thank you for the help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/beginners/attachments/20110406/3cbe802d/attachment.htm>

More information about the Beginners mailing list