[Haskell-beginners] how to update cabal?

Daniel Fischer daniel.is.fischer at web.de
Thu Jun 10 06:18:02 EDT 2010

On Thursday 10 June 2010 11:49:08, Rohit M. wrote:
> I just installed the .dmg fore the Haskell platform.
> When I run "cabal update" in terminal I get the following:
> Note: there is a new version of cabal-install available.
> To upgrade, run: cabal install cabal-install
> I then ran "cabal -V":
> cabal-install version 0.8.0
> using version of the Cabal library
> The latest version of cabal install is 0.8.2.  When I run "cabal install
> cabal-install" it seems to work fine, without any errors but when I go
> back and check i.e. "cabal -V" i still get version 0.8.0.
> I tried "cabal list cabal-install":
>    Synopsis: The command-line interface for Cabal and Hackage.
>     Latest version available: 0.8.2
>     Latest version installed: [ Not installed ]
>     Homepage: http://www.haskell.org/cabal/
>     License:  BSD3
> What am I missing?  It is really annoying that cabal update keeps
> telling me about a new version of cabal-install that I can't actually
> get to work!

The new cabal-0.8.2 is probably installed in $HOME/.cabal/bin and that 
directory isn't in your $PATH. Add it to your path (if it isn't in) before 
the directory where cabal-0.8.0 is in, so version 0.8.2 is found first.

> Thanks
> Rohit

More information about the Beginners mailing list