[Haskell-beginners] Hugs/Haskell Bug

Stephen Tetley stephen.tetley at gmail.com
Sun Aug 22 03:17:01 EDT 2010

Hello David

I've an older version of Hugs installed (Hugs 2003), but the the top
line of ReadP.hs has this pragma:

{-# OPTIONS -fglasgow-exts -fno-implicit-prelude #-}

This means you must to run Hugs with extensions, for the Hugs 2003
that meant running with the command line option / -98 /. For Hugs 2006
this might have changed, though the initial load message should tell
you how to enable extensions.

Hugs is now rather out-of-date unfortunately, unless you are following
a text book that uses it, or a running on a platform were GHC won't
work, then the standard advice nowadays is to use GHC. GHC has an
interpreter, GHCi, that is very similar to Hugs.

Best wishes


More information about the Beginners mailing list