[Haskell-beginners] fail: wxhaskell with cabal

Daniel Fischer daniel.is.fischer at web.de
Fri Nov 27 14:07:39 EST 2009

Am Freitag 27 November 2009 17:51:08 schrieb Josh Bronson:
> Hmm, there is no file of the type you mentioned:
> $ ls /usr/lib/pkgconfig/wx*
> ls: cannot access /usr/lib/pkgconfig/wx*: No such file or directory
> A Google search for "wx pkg-config" appears to reveal that wxwidgets
> does not support pkg-config, or at least it didn't a few years ago.
> Lots of people will try "cabal install wx," right?

Dunno, I just tried, for me it dies with:

<snip more warnings>
     warning: ‘void wxDirDialogBase::SetStyle(long int)’ is deprecated (declared at 
src/cpp/eljdirdlg.cpp: In function ‘int wxDirDialog_GetStyle(void*)’:

     warning: ‘long int wxDirDialogBase::GetStyle() const’ is deprecated (declared at 
src/cpp/eljevent.cpp: In function ‘int expEVT_DIALUP_CONNECTED()’:

     error: ‘wxEVT_DIALUP_CONNECTED’ was not declared in this scope
src/cpp/eljevent.cpp: In function ‘int expEVT_DIALUP_DISCONNECTED()’:

     error: ‘wxEVT_DIALUP_DISCONNECTED’ was not declared in this scope
cabal: Error: some packages failed to install:
wx- depends on wxcore- which failed to install.
wxcore- failed during the building phase. The exception was:
exit: ExitFailure 1

Which reminds me, I've *never* succeeded building wxhaskell, I wonder how many managed.

> So it seems like that's probably not the problem, but I'm not sure where the code that
> is generating the following output lives:
> Configuring wxcore-
> setup: Missing dependencies on foreign libraries:
> * Missing C libraries: wx_baseu-2.8, wx_baseu_net-2.8, wx_baseu_xml-2.8
> I tried untarring
> ~/.cabal/packages/hackage.haskell.org/wxcore/
>z and looking at Setup.hs to no avail. If I could see what test is
> failing, I could probably figure it out.

Specify the locations via --extra-include-dirs and --extra-lib-dirs?

More information about the Beginners mailing list