[Haskell-beginners] Important coding guideline and library proposal

ajb at spamcop.net ajb at spamcop.net
Sun Nov 22 21:54:10 EST 2009

G'day all.

Quoting Daniel Fischer <daniel.is.fischer at web.de>:

> Proposal:
> rename 'length' to   
> 'yesIReallyWantToKnowTheExactLengthOfThisListSoPleaseCalculateItForMe'
> to reduce performance bugs caused by naive uses of length.


Another option is to rename Data.List to Data.List.YesIKnowThisIsNotAnArray.

Andrew Bromage

More information about the Beginners mailing list