[Haskell-beginners] Dynamic libraries not of required architecture when installing via cabal (Snow Leopard)

Malthe Jørgensen malthe_j at hotmail.com
Sun Nov 15 11:42:39 EST 2009

I'm on Snow Leopard, so I've read numerous posts on the subject of GHC  
and it's Snow Leopard (non-)compatibility. I've got most things  
working - I can do a 'cabal update' - something that gave errors  
before. GHC itself seems to be working fine.
I want to install the SDL package from Hackage, which I first tried  
doing like this:
'cabal install sdl'
which gives a bunch of warnings, all looking like this
'ld: warning: in /opt/local/lib/libSDL.dylib, file is not of required
with 'libSDL.dylib' replaced with various *.a and *.dylib files
I then found this in a Usenet post about Snow Leopard breaking GHC:
-- Once cabal works, options --ld-option=-m32 (and also --gcc-option=-  
m32) may be used. These options may also be passed to "./Setup  
And tried this: (I think maybe my problem is that I'm not passing  
these flags correctly to cabal)
'cabal install sdl --ld-options="-arch i386" --gcc-option=-m32 -- 
Well I get the same errors, well warnings actually.
Can I just ignore these warnings?
When compiling my small sample code:
import Prelude
import Graphics.UI.SDL as SDL
main = do
   SDL.init [InitEverything]
   setVideoMode 640 480 32 []
I again get the warnings:
ld: warning: in /opt/local/lib/libSDL.dylib, file is not of required
ld: warning: in /opt/local/lib/libSDLmain.a, file is not of required
and then a bunch of undefined symbols such as:
Well this post basically based on the assumption that the warnings are  
breaking the SDL library and thereby keeping my code from compiling -  
so how do I fix those warnings?
- Sorry for the long mail
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/beginners/attachments/20091115/94a3e4b3/attachment.html

More information about the Beginners mailing list