[Haskell-beginners] Problem installing graphalyze with Cabal

John Velman velman at cox.net
Thu Dec 31 23:08:52 EST 2009

I have Haskell Platform downloaded and installed today.  When I tried to
install graphalyze with cabal install, it had problems with pandoc.  To
make a long story fairly short, I downloaded pandoc-1.3 from hackage, and
tried building it "by hand".  It says it had missing dependencies of
utf8-string >= 0.3, and zip-archive >=0.1.1.

Tried installing them with cabal, and this worked OK.

Still, pandoc setup says:

jrv:pandoc-1.3 jr$ runhaskell Setup configure
Configuring pandoc-1.3...
Setup: At least the following dependencies are missing:
utf8-string >=0.3, zip-archive >=0.1.1
jrv:pandoc-1.3 jr$ cabal install zip-archive-

I _finally_ checked ghc-pkg list, and I have, among other things:

    {HOC-1.0}, {HOC-Foundation-1.0}, binary-, binary-,
    bktrees-0.2.2, darcs-2.3.0, digest-, graphviz-2999.6.0.0,
    hashed-storage-0.3.7, haskeline-, mmap-0.4.1, pandoc-1.3,
    polyparse-1.4, terminfo-, utf8-string-0.3.5,
    utf8-string-0.3.6, zip-archive-, zip-archive-,

As you see, I've ended up with two copies each (because of my messing
around before I checked ghc-pkg, I guess).  Well, all of them are >= the
dependency requirements, If I understand correctly.

What gives?  How do I get rid of the extra copies?  (By the way, the HOC
entries are left over from an earlier time, and I'd like to get rid of
those also).


John Velman

More information about the Beginners mailing list