[Haskell-beginners] Advice on what to install

Stephen Blackheath [to Haskell-Beginners] mutilating.cauliflowers.stephen at blacksapphire.com
Mon Dec 28 15:09:53 EST 2009


Whatever ships with the platform is usually best.  ghc-6.10 is very
stable, but ghc-6.12 has only just been released and so some libraries
on hackage don't work with it yet.  So, 6.10.4 is the best version to
use at the moment.

Welcome to the list - please ask away, and I hope you have fun learning


Chris Saunders wrote:
> I noticed the availability of Haskell Platform 2009.2.0.2 and did
> install this and when I run GHCi it says that its version is 6.10.4. 
> Now on the GHC site I notice that the current version is 6.12.  Should I
> have installed this more recent version or  stick with what I have? 
> Warning: many more dumb questions to come from this guy.
> Regards
> Chris Saunders
> ------------------------------------------------------------------------
> _______________________________________________
> Beginners mailing list
> Beginners at haskell.org
> http://www.haskell.org/mailman/listinfo/beginners

More information about the Beginners mailing list