[Haskell-beginners] plugins package

Daniel Fischer daniel.is.fischer at web.de
Wed Aug 27 16:15:50 EDT 2008

Am Mittwoch, 27. August 2008 21:31 schrieb Emmanuel:
> >> I am having troubles bulding the plugins package :
> >>
> >> manu:~/Desktop/tmp manu$ cabal install plugins
> >> Resolving dependencies...
> >> cabal: cannot configure plugins-1.2. It requires ghc >=6.8
> >
> > That is the ghc-api package, of which it requires a version >= 6.8.
> > Could you verify that you have it installed (ghc-pkg list will tell
> > you what
> > you have)?
> it's not listed by ghc-pkg list, I have ... {ghc-6.8.1}, {ghc-6.8.2} ...
> where do I get it ? It's not listed on Hackage

If the output of your ghc-pkg list contains something like
filepath-, (ghc-6.8.2), haskell-src-,
you have the package (the parentheses indicate that it's hidden), version 
6.8.2 in this case, which clearly should be >= 6.8.

Then I don't know what the problem is, maybe it would work if you manually 
exposed the package before cabal installing, but I doubt it.
Have you tried to manually go through the 
runghc Setup.lhs configure / build / install
If your version of cabal install isn't new enough, have you already tried 
upgrading that?
If nothing helps, ask on Haskell-cafe, there are people familiar with the 
workings of cabal there.

> Thanks
> Emmanuel

More information about the Beginners mailing list