[arch-haskell] Can't install cabal-install

Magnus Therning magnus at therning.org
Wed Apr 16 05:02:44 UTC 2014

On Tue, Apr 15, 2014 at 11:39:15PM +0200, Marcelo Garlet Millani wrote:
> Hello,
> Trying to install cabal-install through cabal is not working for me. When compiling the module:
> HTTP-4000.2.4
> I don't know why it's trying to install HTTP-4000.2.4 when the
> newest version is 4000.2.12 and cabal-install depends on HTTP >=
> 4000.0.8 && < 4001 .
> Is there anything I can do to fix this problem?

I'm no user of cabal myself, but a few days ago when I thought I'd
take a look at the sandboxing feature of it I ran into a similar
situation, cabal wanted to install an older version of some package
for no apparent reason.  I just gave up and decided that I'd have to
postpone playing with cabal :)

HTTP 4000.2.12 is in [haskell-core].


Magnus Therning                      OpenPGP: 0xAB4DFBA4 
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

I invented the term Object-Oriented, and I can tell you I did not have
C++ in mind.
     -- Alan Kay
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20140416/29cdb93a/attachment.sig>

More information about the arch-haskell mailing list