[arch-haskell] What happened to darcs?

gdweber at iue.edu gdweber at iue.edu
Sat Oct 12 07:40:22 UTC 2013

I am wondering what has happened to the darcs package -- it seems to have
disappeared sometime between November 6, 2011, and today.

I know I installed it on Nov. 6, 2011, and I believe it was from
one of the standard repos like [community] or [extra].  

>From /var/log/pacman.log:

[2011-11-06 15:56] Running 'pacman -S ghc emacs-haskell-mode cabal-install darcs gnupg'
[2011-11-06 16:00] installed darcs (2.5.2-1.1)

Today, my installed version of darcs is still 2.5.2-1.1,
but when I search for it darcs with pacman --

# pacman -Ss darcs

gives no result, and likewise searching in the package
database finds nothing --


The latest I can find any discussion about it on this mailing list
is from Thomas Dziedzic on 2012-03-03, ending with this statement:

"*There is no cabal-install or darcs version that is marked as stable
and currently builds with ghc 7.4.1
These packages are statically linked so it shouldn't matter for now.
I will be keeping an eye on these packages and waiting for upstream to
provide new stable versions that builds against the latest ghc."

That seems to mean that the package would remain a package, only 
it would not be updated for a while.  But in fact my search results
seem to show that it is no longer a package at all.

Meanwhile, darcs 2.8 is available, and is supposed to support GHC 7.4.x:


Gregory D. Weber, Ph. D.                  http://mypage.iu.edu/~gdweber/
Associate Professor of Informatics        Tel (765) 973-8420
Indiana University East                   FAX (765) 973-8550

()  ascii ribbon campaign - against html e-mail 
/\  www.asciiribbon.org   - against proprietary attachments

More information about the arch-haskell mailing list