[arch-haskell] Upgrading to monad-control-0.3

Nicolas Pouillard nicolas.pouillard at gmail.com
Sat Oct 12 07:39:50 UTC 2013

On Tue, Jan 3, 2012 at 7:11 AM, Magnus Therning <magnus at therning.org> wrote:
> On Mon, Jan 02, 2012 at 07:38:59PM -0800, Leif Warner wrote:
>> I'm hoping the version of text in [extra] can be upgraded - I just
>> left a comment on xmobar-git [1] that it's been marked outdated
>> since last month, and is behind Haskell Platform.  It's blocking
>> upgrade there, too.
>> [1] https://aur.archlinux.org/packages.php?ID=44683
> Slightly off-topic, the version of text in the latest haskell-platform
> still isn't the latest ( vs. so this situation is
> bound to come about again in the near future.

Indeed but I support the concept of the haskell-platform. It is too
restrictive to only packages able to track the latest versions of
their dependencies.

I suggest we try this technique on one case first and the text package
seems to be a good example. We could package the latest version of
text and upgrade some package which depend on it.

Nicolas Pouillard

More information about the arch-haskell mailing list