[arch-haskell] [arch-general] Haskell Support Was: Xmonad version?

Mike Bonar oldpond at gmail.com
Sat Oct 12 07:39:48 UTC 2013

On 12/23/2011 06:29 PM, Fabio Riga wrote:
> 2011/12/23 Bernardo Barros <bernardobarros2 at gmail.com 
> <mailto:bernardobarros2 at gmail.com>>
>     Why can't we just update to ghc 7.0.4 for now? Nothing will break,
>     look at the bugfixes:
> Actually /everything/ will break: every time we update ghc, we need to 
> recompile every package depending on it (i.e. every haskell package). 
> No matter what version we upgrade to.
>     BTW Fedora is doing a better job with Haskell then Arch now. they
>     updated to 7.0.4 and are supporting a lot more packages. And now we
>     are dropping packages.
> We are here to make Arch a better distro for Haskell.
>     I think haskell packages are indeed a bit trickier then normal
>     c/c++/python/etc libraries and packages, since their dependencies
>     seems to be much stronger. And keep in mind "rolling release" does not
>     mean "unstable" or "testing", it just means that we don't have
>     releases but the system must always work and must be stable.
> ... with the last stable version available.
>     It we are going to be a "experimental" with 7.2.2 (which I think it's
>     a mistake) we have to have a mechanism to ensure that at least a set
>     of important packages used in production will never break, that there
>     are quite a few of them.
> That's exactly what cblrepo is used for? Am I wrong?
> It seems to me that the meaning of "testing" in 7.2 branch is about 
> "new features that could change in 7.4"; it's not about "breaking 7.0 
> branch".  What works with 7.0.4 should works as well with 7.2 (and 
> actually do!).
> Look at this: 
> http://www.haskell.org/ghc/docs/7.2.2/html/users_guide/release-7-2-1.html.
> I made a testing repo and updated to ghc-7.2.2 some 100 packages, and 
> everything looks okay. For me it's the same, we can use both 7.2.2 or 
> 7.0.4. During Christmas holiday I have enough time to try and build 
> most of packages for one of those. If Magnus agree.
> Witch version should I use? For now we have 1 vote for 7.2.2 (Magnus) 
> and 1 for 7.0.4 (Bernardo).
> Fabio
Well, if we want to get leksah working it requires haddock which now 
depends on 7.2.  I'm not sure how many use leksah, but that's a vote in 
favor of 7.2.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20131012/f8acaf1f/attachment.html>

More information about the arch-haskell mailing list